Cumulative Energy Consumed - Stuck


I’m having a problem uploading my consumed energy - for some reason, it’s “Stuck”. As far as I can tell, I’m sending the correct values; but it’s not displaying correctly. Is there a way I can see the “raw” data?

Has anyone seen this?


OK - this is really weird - here are two images from the same day -



I have NO idea what’s going on…


Still “stuck” today; but it’s stuck at yesterday’s max consumption. The problem started when I moved my upload task from “cron” which runs every 5 minutes at 0, 5, 10,15, 20, etc to an agent that runs every 300 seconds from the time it started; which might be 01, 06, 11, etc.



Energy should always start at 0Wh at the start of the day.

e.g. The 27-Sep 0:05AM consumption value logged of 40850Wh is incorrect, this seems to be carried over from the previous day.

Data from 0:10AM (172Wh) on-wards is correct and lower than 40850Wh.

Energy will be ‘stuck’ when a lower energy value is received for a later time. The graph/table data will never display decreasing energy data.

Best to disable your energy upload (v3=-1) and only send power, PVOutput will calculate it in this instance.


OK - that’s what I was thinking happened. The change in “When energy resets” is an artifact of the timing on my upload scheduler… So, just to confirm, I can send V3=-1 and PVOutput will calculate the “correct” value?



Yes, as long as v4 is sent.


OK - I’m doing that (sending V4 and V3) and it’s still picking up the previous day on the “live feed”


OK - this is really strange. I’m using the latest version of Windows Edge - when I first connect to pvoutput and click “Live” I see this:


If I leave the browser alone, after the next upload, I see this:

If I hit the browser refresh, or click “Live” again, it reverts back to the first screen.


v3 is still being sent with an incorrect value for the previous day at 00:05.

Please send v3=-1 or remove and will be calculated from v4.

e.g. of current request -

  • /service/r2/addstatus.jsp?key=*&sid=63078&d=20201009&t=04:04&v1=0.000&v2=0&v3=8440.000&v4=1825&v6=0.00

Should be -

  • /service/r2/addstatus.jsp?key=*&sid=63078&d=20201009&t=04:04&v1=0.000&v2=0&v4=1825&v6=0.00


Can you verify the accuracy of the PC’s clock and the Inverter’s clock?


My bad - I tested the new version (with -1) but never moved it to my “production” spot.

Thanks for the assist and for making this available