CT Clamp problems since adding PV Solar - CT placement?


#1

https://pvoutput.org/intraday.jsp?id=66193&sid=58867&dt=20180930

For months i’ve been monitoring household consumption prior to getting Solar. The CT Clamp has been in this location all that time.

As you can see, up to a few days ago its been collecting data and uploading via a Current Cost Envir monitor and Raspberry Pi running measureit.

I had Solar PV installed on Thursday and since Friday I have been uploading generation to PVoutput via my SolarEdge API in PVO settings. Which seems to be working ok.

But since the minute the Solar went live the CT clamp doesn’t only show consumption, it seems to be a combination of generation and usage. I can’t quite work it out. The only time the consumption seems true (as per the previous months) is when there is no generation (ie through the night etc)

Is there anywhere else I could place the clamp so that I can show home usage only?

I can obviously get generation direct from Solar Edge, so I don’t really need generation, just consumption.

Thanks in advance for any help, tips and suggestions.


#2

You need a clamp on solar input and another on consumption “Teed” off the main switch.


#3

Assuming you have a single phase system, which this appears to be, your are now measuring NET power with your CT.

With the equation:

NET = PRODUCTION - CONSUMPTION

Measuring any two of these quantities will determine the third.

The information on your site indicates that both the SolarEdge inverter and your CT are already setup.
You need to set up your CT to indicate it is measuring NET instead of CONSUMPTION. To do this click on your System Size number following your System Name on the default page of your PVOutput webpage. Scroll down to the Automatic Uploads section and note which device (Primary or Secondary) is your CT and change the “Direction” indicator from Consumption to Net. You may also want to enable the Temperature and Voltage boxes to record the Inverter temp and DC voltage for the SolarEdge inverter.

Good luck :grinning:,


#4

In addition to the suggestion to change your PVOutput to a ‘net’ setting - can you get access to the breaker board where all the individual circuits for power points, lights, oven, etc are?
Usually, after passing through the meter where it looks like your clamp currently is, the main phase then goes to a distribution board where all the individual house circuits star from. If you can move the CT clamp to one of those wires feeding into the distribution board, you may get back to a situation where the clamp is just measuring consumption only.
Stay safe playing back there, looks like you have a very old installation!


#5

As the input from measureit/currencost is squirted directly in to PVO using the API I don’t see anywhere within PVO to change any settings for that.

I only have SolarEdge set as my primary device… in essence PVO only sees one device (SolarEdge) with the other data coming externally from measureit on the Raspberry Pu. So i’m confused where to make the ‘net’ change. I have nothing as my ‘secondary’ device?

https://lalelunet.gitlab.io/measureit/


#6

https://pvoutput.org/help.html#api-addstatus

you need to add the net command to addstatus link. i dont have my measureit device available but this thread should give you the location and or any other help you need.

https://groups.google.com/forum/#!topic/measureit/n2bZC2jIhuw

the link should be something like
url = 'https://pvoutput.org/service/r2/addstatus.jsp?key=’+sensor_settings[sensor][‘pvoutput_api’]+’&sid=’+str(sensor_settings[sensor][‘pvoutput_id’])+’&d=’+sensors[sensor][‘pvoutput_watt_sum’][‘day’]+’&t=’+sensors[sensor][‘pvoutput_watt_sum’][‘time’]+’&’+type+’=’+str(sum)+’&v5=’+str(tmpr);

you need to add &n=1 to the end of it


#7

Thanks @B-Man ,

Have made that change to the Python code, so keen to see what happens through today. :slight_smile:

https://pvoutput.org/intraday.jsp?id=66193&sid=58867&t=0&gs=0&da=1&s=1


#9

i was a little confused at how measureit has the + ’ etc so hopefully you have done it correctly and it should be sweet.


#10

First attempt failed trying to tack it on the end, so I smuggled it in the middle of the code line. :slight_smile:


#11

Still not convinced this is working properly or reporting accurately today.

https://pvoutput.org/intraday.jsp?id=66193&sid=58867&dt=20181003

The consumption and generation are still tracking each other.

I sort of believe the ‘consumption’ when there is no PV generation… ie through the night. That seems to match what was being recorded before the PV install. But as soon as the PV kicks in, the consumption figures just don’t seem right.

Its like the clamp doesn’t know exactly what’s going on in/out?

Is it really ‘total seen from the clamp’ - ‘generation (from Solar Edge)’ = consumption?


#12

yes

i dont think your net command is working correctly. can you show how you have put it into the addstatus url…


#13

Can’t get until I get back home… will have another play tonight. :slight_smile:


#14

id try
the link should be something like
url = 'https://pvoutput.org/service/r2/addstatus.jsp?key=’+sensor_settings[sensor][‘pvoutput_api’]+’&sid=’+str(sensor_settings[sensor][‘pvoutput_id’])+’&d=’+sensors[sensor][‘pvoutput_watt_sum’][‘day’]+’&t=’+sensors[sensor][‘pvoutput_watt_sum’][‘time’]+’&’+type+’=’+str(sum)+’&v5=’+str(tmpr)+’&n=1’;


#15

yeah, i’m thinking I didn’t do something right with the single quotes. :frowning:

Although i’d have expected everything to fail if there was a problem with the syntax.

It would be good if the measureit author could add a net option per clamp/sensor in the gui. :smile:


#16

Grrr, super frustrating. I dropped the code change in last night as suggested (basically copy/paste) but still no apparent change. Its still reporting as following generation. Despite giving the whole Pi a reboot to ensure it picked the code up.

Not sure what to check now?

Is there anywhere within the belly of PVO to see what is being submitted from external sources?

Also, as the data coming from the SolarEdge API seems to be every 15 mins, but the data from measureit is every 5, could that present a problem with any calculations? I see there is a delay flag in the addstatus API?


#17

im not certain how i typed it is correct but that’s how i would of tried it.

could you add an echo for the link and run the grabber manually to see whats being displayed?

quite possibly. could you change the inverter to add every 5 minutes instead?


#18

I think the SolarEdge timing is bound by the daily usage limits of the SE API?


#19

ah ok can you set the upload from measureit to 15 minutes?


#20

Maybe that is something else in the measureit code that needs tinkering with? :roll_eyes:

Oh what fun!! :smile:


#21

maybe you need to change from measureit to pvoutput integration service. although i cant see an option to enable net