Consumption & OpenWeatherMap data seems to have stopped being received

I’m not seeing any further Automatic Upload "Consumption & OpenWeatherMap data, on PVOutput. Just seemed to have stopped this morning at 2:25AM 15/4/2022 (South Australia). This also coincides with another user’s PVOutput data using the same energy monitor (Smappee) I’m using.

From my end, the Smappee data is showing up on the Smappee Dashboard site (, so I gather this has something to do with PVOutput as I have both Consumption data & OpenWeatherMap data configured through PVO settings?

Has anyone any further insight on how to resolve this?

Sorry, don’t know how to resolve, but I have the same problem. Stopped at 3am this morning - Smappee upload / transfer used also.


Thanks for letting me know, at least I’m not the only one affected by this.

@bankstownbloke Could you please confirm?

Hello, another smappee user here with no import data being displayed.

My Smappee stopped uploading after Thursday, April 14th; so I was missing 15th April onwards.

I investigated this morning (UK) (Monday, April 18th). Couldn’t spot anything obvious in my Settings.
I saved the Settings and noticed it had all sprung back into life. Readings for the 17th and 18th were uploaded from Smappee but not for the 15th or 16th. I have done a manual entry to record the total generated and exported for those two dates, which will at least keep the overview up-to-date.

So it appears to be resolved for me but not sure what caused the issue, whatever it was, in the first place.

1 Like

Thanks for that, going into settings then saving worked for me.

mmm, it didn’t work for me! :face_with_thermometer: Even tried a software restart within the Smapee GUI, same.

Still experiencing no Consumption & OpenWeatherMap data showing up on PVO.

Note if the Smapee was offline more than 24hrs then the system upload is removed. To restart the upload, edit the PVOutput system setting and click “Save

Hi, thanks for replying…

1/ The Smappee hasn’t been offline, as it wouldn’t be registering consumption data on the Smappee website (see graphic), showing consumption data has been received since the PVO upload issues started on the 15/4/22

Also I had sneak-peek at the Automatic Upload section, the ‘Direction’ flag is still set at ‘consumption’!

I did notice however, that if I try to save any settings, the site comes back as if I hadn’t input an ‘Install Date’? changing this value comes back with the same error i.e. to Enter date in yyyy-mm-dd
2/ I also have the ‘Weather device’ set to OpenWeatherMap, this tests fine on PVO (pressing the ‘test’ link), but this is also not being upoading to PVO?

The openweather config now requires a location, otherwise it won’t save.


Click on the Retrieve button to fill the location fields. You should now be able to Save at the bottom.

Yeah I tried to add the ‘Location’ field (Weather Device & API Key populated), but yet again I find the site wants me to enter an ‘Install Date’, so not able to save any changed data.

If I change the date the same occurs. Thought it may be a browser issue, tried latest Firefox / Edge the same again?

The install date is an optional field so it should not error when blank. Try logging out and clearing the browser cache.

Whohoo! Thankyou, following your instruction I omitted the Install Date completely and was then able to save.
Somehow the (old pre-populated/newly entered) ‘Install Date’ caused the error (giving me the continual prompt to re-enter a date).

I followed up by entering the older pre-populated ‘Install Date’ and again saving successfully!

FYI, my browser(s) were set to automatically clear it’s cache upon closing.