Change of the day


#1

Hi,

I have a Solaredge, and update all the values to my PVOutput account with the use of API.
So far so good. I installed a Raspberry with Domoticx where i calculate the power consumption and keep track of the consumption of natural gas.
I use a script to update those values with the use of API too PVOutput.
The power consumption values are fine, but i have a problem with the natural gas update during midnight.
Yesterday
Today

Take a close look at the midnight values :slight_smile:
Do i use a wrong setting?
Anyone a solution?

btw: The clock on the PI and PVOutput are syncronised, and use extended upload.


#2

Hi this nay be your problem the time in the PI moves about a bit,DELTA SECONDS - COUNT
0 - 176
1 - 1804
2 - 2076
3 - 1279
4 - 704
5 - 599
6 - 128, as you can see,just enough to throw off the midnight readings especially if the gas is the last on the list in the PI for the extended data jim
With myRPI i have a 10 second delay after the 5 min time


#3

Oké, thanks for the response. Have to see how to solve this.


#4

Is the issue is that you wish to record the last 5-minutes 11:55PM to 12:00AM ?


#5

The problem is that the values from 23:55 lifted to 0:00 the next day at 0:05 they will corrected with
a -value. So i’ve got a spike around midnight.


#6

Simplest solution is to update the script to not send the 0:00 data point.

Alternatively you can use an Extended Data Rule -

e.g.

if (hour==0 && minute == 0) v7 = 0

Always sets v7 to 0 at 0:00 regardless of what is uploaded.


#7

Thanks @bankstownbloke, never thought about that option.