Can't Edit on My Outputs page


Since 1st March the “Edit” link is missing from the “Your Outputs” page for each day’s statistics.

Normally my monitoring system automatically uploads the inverter data, but at the end of each day I have to upload the feed-in numbers manually. Normally I do this via “Edit”. But since it is missing now I don’t have a way to enter my feed-in data.

Am I missing something? Or is this a new bug?


It’s a change that seems to have confused a number of people. See here Checkbox and Edit links hidden by default - #8 by bankstownbloke


Hi Bob.

Thanks for your reply. I think I understand the workaround now.

It seems to be a design idea straight out of the textbook of non-obvious non-discoverable non-intuitive designs. How would anyone be expected to know? - the page seems identical to the page that you see when you aren’t logged in, making me think the login was the problem!

Maybe that’s what the kids like these days…

Thanks again,

It’s proved that most of us ‘older’ kids don’t like it and the boys at PVoutput have reinstated them as they were previously.