Cannot adjust 'System Cost' setting

As I set up my PV system 2 years ago, I entered only the approximate system cost.
Now I’ve calculated the exact system cost and wanted to correct this value in my settings. But as often I save the new setting, it every time jumps back to the old, wrong value?
What do I wrong?


Hi again
I just asked a friend who is also a member of PV-Output; he hadn’t entered any system costs yet, but he couldn’t save a new entry either.
It doesn’t look like I’m doing anything wrong…

Hi @rk_aus_s. My SYSTEM COST is set. As a test I changed it, saved it and then checked to see if the change had been saved. It had. I have since successfully changed it back.

After you change the values and then press the SAVE button are any error messages appearing? I’ve been caught out before where a change failed to take because of an incorrect setting elsewhere. An earlier setting that you have used for your system may no longer be valid or a secondary change has rendered a setting invalid.



I tried it again:

As since a time ago, I get as usual firt the Enphase API upgrade warning; I’ve already done this API adujustment, so I click ok:

Then I set the new value:


I click “Save” at the bottom:


After saving, I recheck the value:


Now, I leave the ‘settings’ and re-enter the ‘settings’ again, and my old, wrong value is back:


I cannot see any error message or something similar.
My colleauge and I both use Enphase, could this API warning be a reason that the SYSTEM COST cannot be saved?
And, I can confirm that if I change another value, for example if I enter some REMARKS, they aren’t saved as well. It seems to an issue with the saving function rather then which field is changed.

Kind regards

I do not think that you should still be seeing the ‘Enphase API Upgrade’ warning.

Have you altered the Automatic Uploads section within Settings to reflect the fact that you are using v4 of the Enphase API?

1 Like

The Enphase v2 warning only pops up if the system is still on “Enphase v2”.

When an existing system with Enphase v2 is edited the popup will show and it automatically switches the Auto Uploader primary/secondary configuration to Enphase v4. But an authorization is required with the Enphase portal to setup Enphase v4.

Only when the authorization on Enphase is completed successfully can the PVOutput save correctly.

This is preventing any changes from being saved including the “System Cost”.

See the below on authorization steps / setup -

Many thanks.
I did exactly what is described in the link and could succesfully re-authorize, but the new settings are still not saved and my directions (Primary and Secondary) are not consoldidated to “Both” as well.

Do I understand the descriptions right; can I leave the same User-Id as it was with Enphase API v2?
Do I really only have to click “Authorize” → “Allow Access” → “Save” and all is done?


Even it seems re-authorization was successfull, I still cannot save afterwards.

Addendum (solution!)
After playing around why my settings aren’t saved at all, I finally found the reason and solution!
The two fields for the OpenWeatherMap were empty, this was the reason nothing was saved. Just unfortunate that the web form didn’t give me any feedback, what actually wasn’t correct!
I only had to click the “Retrieve” button to get my Location coordinates.

Nevertheless, thank you all for your support! :slight_smile:

1 Like

Thank for this - saving does focus on the empty field, it would probably be changed to a red background colour in the future to make it more obvious that it is required.

Note - screenshot removed with openweathermap API key in it.

Great, thank you as well for your support.