Automatic Uploads - Secondary Device - Efergy - combining two inputs


#1

Can anyone guide please? I am using Efergy Engage with four devices: two monitoring solar production (two different arrays) and two monitoring consumption - my house and my pump shed.

I have my primary device set to my inverter which combines my two arrays for production.

My Secondary Device is set to Efergy, and direction is set to consumption. Power is set to my house device, and I have added my pump shed device as one of the extended options.

Is there any way that I can combine both my house device and pump shed device together so that I have only one consumption?

(Ideally it would be nice to be able to see the house and pump shed as separate options, and combined).


#2

Yes there is a possibility. I load my solar panels to an Arduino micro computer and use one of 4 inputs. If I want to ad another array I have to use a second input. Inside the Arduino these values are added together and the result is visible at PVOUTPUT


#3

The secondary device is currently limited to 1 stream.

The only way to combine all four is to use Data Aggregation with 2 systems.

https://pvoutput.org/help.html#general-aggregation

  • System 1 - Primary Only (Production x 2 + Extended)
  • System 2 - Primary Only (Consumption x 2)
    • Under Data Aggregation section of System 2
    • Parent = System 1
    • Aggregation Mode = Consumption

System 1 will now have a copy of the combined Consumption of System 2.


#4

Thanks for your guidance, but I’m lost.

I’ve set up a second system and have my two consumption added to each other, so I now have a total consumption.

However, this step is confusing me:

I am not sure where I a looking I am looking for these settings…I appreciate if you are able to offer further advise.


#5

To setup system aggregation, edit each child system and assign it a parent -

  1. Login
  2. Click on Settings
  3. Goto the Registered Systems section at the bottom of the page
  4. Click on Edit next the system to open the system editor
  5. Goto the Advanced Settings section
  6. Select the parent system from the Parent System dropdown

When I follow these instructions, I am not seeing Parent System


#6

Hi I got a msg from you but never actually commented on here so unsure how you chose me.
When you click edit on the child system scroll down to the bottom then a few headings up just above extended data there is data aggregation

Chose your parent system and correct settings from there


#7

Its under the Data Aggregation section -

image