Automatic upload from Smappee to PVOutput - Newbie needs help


#1

First post here and completely new to PVOutput. I have a Smappee and have been reading its outputs on the Smappee web interface and Android app… all working OK.

Have registered and created a new system in PVOutput. But I can’t get my Smappee data to upload.

On the main settings page:
System shows as active
I currently have the API enabled - but have also tried it as disabled

Screenshot of settings follows

Can anyone help? I can’t find much detail in the relevant FAQ/Help pages on Smappee or here… or with google.


#2

The Smappee settings are correct, there are some non-standard characters in the password.

Try editing the system and clicking on Save.


#3

This isn’t required when using the Auto Uploader.


#4

That’s fixed it… changed the Smappee password so no non-standard characters.

Now to explore the other settings.

Much appreciated bankstownbloke!


#5

Hi Dave
Im stuck on getting a token, do I have to?
How do i do a HTTP Message?

Is Secret Client the token code?

I really need some help!!!

Client id looks like 1007500xxxxxx this the ID they are talking about?


#6

From memory, you can get the client ID and the client secret from support@smappee.com

Not sure what you mean about the http message or the token


#7

They emailed me, and apparently for a small ongoing fee I can get it from Smappee $$$$


#8

That’s no good! Was free when I got set up for Smappee upload to PVOutput.

Maybe because I was a Smappee Kickstarter backer.


#9

$5.00 per month for 24 months. The price for their units and plugs have gone through the roof.


#10

As far as I can tell, live data from my Smappee remains good… matches nicely with another push from Fronius meter.

But, for the last few weeks, daily, weekly and monthly stats don’t look right. Generated matches Exported and Consumption matches Import.

I have a third system set up… using exactly the same Smappee upload. (I use it to compare alternative rates). Its daily, weekly, monthly stats look about right to me. So I’m guessing the problems isn’t at the Smappee end. I’ve compared the settings of the two systems and they match exactly except that Net Power Tracking is enabled in my main (currently reporting incorrectly) system. I can’t see how this could be the problem but I’ve disabled it and will keep an eye on things over next few days.

But would be grateful for any tips if I’m barking up the wrong tree. Also very grateful for tips on how I can fix the stats retrospectively without going through and editing each day manually - so I can more accurately compare plans going forward.


#11

Replying to my own post above, and appreciating that there are probably not many PvOutput users with Smappee upload…

disabling Net Power Tracking hasn’t helped. Live stats still don’t match up with daily, weekly and monthly ones.

Maybe someone has some ideas?


#12

You should probably check the installation of your CT’s. Since they are directional they need to be “pointing” the right direction. In general the side of the CT with printing should face the source of power. If the CT is installed incorrectly your values out will be negated for the CT’s which are reversed.


#13

Thanks. But I can’t see how it could be that.

The clamps haven’t been moved for 4 years and all has been OK until a few weeks ago. And, as I say above, I have another PVOutput system running perfectly well using exactly the same Smappee upload (ie the same clamps). And also that my live values seem fine as well.


#14

I see that you system now reports Solar = Export and Consumption = Import. I looked at the Smappee setup and there are three choices for the input. Solar, Consumption and Net. Have you tried the other two. It looks to me like since you Smappee is measuring both Consumption and Solar you should set it to Net. I don’t know how you setup is but my Neurio, which does essentially what your Smappee does, is set to measure Net and Solar. Since the PVOutput API doesn’t accommodate the Neurio I have to send my data by my own app running on a Raspberry PI.
Depending on how your CT’s are arranged and how you Solar feeds into your power panel you should be able to analyze the problem. You need to know what data Smappee is sending in order to determine why PVOutput is reporting that you export every kWh and import every consumption kWh. That would be true if you were using “supply side connection”. This is where the Solar production is connected directly to the feed in lines from the power company. In this case you will never see NET because it looks just like a system without Solar. Here in California we have to connect our solar to the last position on our power panel. This insures that the Solar goes first to the house circuits and only the excess power is fed into the Grid. PVOutput is treating you system as though it were a supply side connection. You will have to have bankstownbloke analyze what data is being received and how it is being used in the sample report bove.


#15

Thanks Iwsmiser. I really appreciate you making such an effort to help.

But I can’t see how the CT’s or Smappee has anything to do with it. As I say above, the clamps have been in place for years and the Smappee has been uploading perfectly well for the same amount of time. As an aside, I do have net selected.

If you have a look at my post 9 days ago, you’ll see that I have two PVOutput systems running… both of them use the same Smappee device and same API. One of them is working as expected. But one of them stopped working a few weeks ago… as per the screen shot I uploaded and my description above.

So, to my unsophisticated way of thinking, there must be some problem in the settings at the PVOutput end. But, as I say above, the settings look very similar to me. There was only one obvious difference but, when I changed the relevant setting, it made no difference.

Someone else might have some ideas… would be great if Bankstownbloke had time to look in to it. It isn’t really a problem for now, will only be an issue when I consider switching power plans in the future.


#16

Please provide a link to the system


#17

Thanks

https://pvoutput.org/intraday.jsp?id=28424&sid=26032 is the one that is not reporting as expected

The one that looks OK - uses same Smappee device - is at https://pvoutput.org/intraday.jsp?id=28424&sid=59437


#18

System 26032 has activated tariff plans, however none of the plans are active.

See thread below -

Hovering the mouse over the daily balance will show which plan is currently active.

For system 59437

image

The plan line is missing from 26032 meaning there are no matching active plans.


#19

your support much appreciated BB.

Not sure how that happened. It was working before. Would like to blame someone else but I can’t find anyone but myself.

All fixed now… and tariff applied to the relevant dates so all is good with the world.