Assistance with addstatus curl

I reported an issue with my extended data a couple of days ago which has attracted zero responses and so I am trying to explore what the issue is further. I have tried sending generic data via curl and did manage to get my data into v7 if i specified the date and time and data explicitly. I then tried to go back to strftime and date but get a 500 error. I believe i have written this correctly. Any ideas?

curl -d “d={{now().strftime(”%Y%m%d")}}" -d “t={{now().strftime(”%H:%M")}}" -d “v7=15” -H “X-Pvoutput-Apikey: MYAPIKEY” -H “X-Pvoutput-SystemId: MYSYSTEMID”

I am also still seeing strange data populating v7 even without any POST by myself… just very odd random numbers appear without input.

Any guidance would be appreciated as to why my curl command using now() is not working.

(edit, the 15000kWh at 15:15 was my test using an explicit date, time and data number)


is the timezone of the device correct?
what time does now() output?

Hi @markwoodward86

In the sample code that you show above you are trying to push a value into v7 - only.

According to the documentation though API Specification — PVOutput documentation

1 At least one of the values v1,v2,v3orv4 must be present.

Alternatively if you become a ‘Donor’ Donations — PVOutput documentation

Add Status

  • The d date parameter must be not be older than 90 days from the current date.
  • Extended parameters v7, v8, v9, v10, v11 and v12
  • Maximum energy consumption v3 value increased to 9,999,999Wh
  • Maximum power consumption v4 value increased to 2,000,000W
    > * Temperature v5 and Extended parameters v7 to v12 can be sent without v1 to v4
  • Text message m1 parameter can be used as part of a custom alert subject or body message.

v1 and v3 are expected to be in Wh not kWh - if that relates to your 15000kWh figure shown above. Similarly v2 and v4 expected to be W rather than kW.

I am a Donor and I use addstatus to uploaded ‘Extended Parameters’ on their own.


thank you for your comment.

Timezone is confirmed to be correct both on my server and on PVOutput. It should also be noted that i use the same cURL (with URL and datapoints tweaked) for the addoutput endpoint and do not have any issues.

Thank you all for the comments, I believe the issue was that I had activated v7 elsewhere to show humidity so when i added v7 for my production meter value it was not being accepted as the temperature value was taking precedence. May be a good enhancement to have those options for extended data to be in the same place or at least grey out the config settings for those values already existing elsewhere in the settings menu?