All outputs showing as zero - SBFspot


#1

Hi All,
I’ve got an SMA that uploads it’s data via SBFspot. Its been working happily for years until yesterday when all my values shown on PVOutput are shown as zero. Looking at the SBFUploadDaemon log everything appears okay (i.e. Date, Time, Total Generation, 5 min generation,Temp,Voltage -> OK (200)) are all correct, it’s just that PVOutput isn’t then displaying those values.

I’ve uploaded some 5 minute data manually this morning but thats not really a workable long term solution.

Does anyone have any idea?

Thanks
Andrew


#2

You’ve maybe already tried it but the first thing I’d do is restart the pi.

Bob.


#3

Yep, That was my first step as well. Since then I’ve tried upgrading SBFspot to the latest version, downgrading it to the previous version, reinstalling the current version - all with no success.

It really seems like the issue is at the PVOutput end as the SBFspot logs all indicate that it’s uploading the right data in the right format.

Its got me stumped…

Thanks
Andrew


#4

well it seems to be working today, your system showing just over 15 kwh today so far 19/6/2020


#5

No, I manually uploaded all of those… Wanted to make sure they were up there before deleting and re-creating the database.


#6

As you can see, from 14:40 all the values are zero again.


#7

although your power used is still going up, so some thing is working was it a restart of your PI or a reboot of it ??


#8

Yep, thats the consumption data that is fed by Efergy. It’s the generation data that has gone awry.


#9

Try setting the pvoutput flag to null in the daydata table to re-upload the data. Maybe there was some issue at pvoutput side.
You didn’t change anything for consumption upload which could overwrite generation data?


#10

I didn’t change anything anywhere. Tried setting the pv to zero but will give null a go as well. Having said all that it’s working happily again today.

Fingers crossed it stays that way.

Thanks all.