Agregating output despite parent system 'None'?


I have 4 systems on PVOutput:
84236 is de main system, pulling data from SolarEdge just fine.
At the moment I do overwrite this with a script using data I pull from SolarEdge monitoring website (daily, or less frequently, scripts started manually right now)

There are 3 ‘child’ systems:
86413, 86745, 86746
These only receive data via API pulled by my scripts from SolarEdge monitoring website (They represent groups of panels in the main system). I did have these configured as child systems initially, but de-configured that - all have parent system none now.
The data from the solaredge website is probably DC data before conversion losses, so they are not a good source for aggregating into the parent.

Unfortunately I have the impression some aggregation into the parent ‘Output’ is happening still. My scripts also load consumption data into the parent output; and this sometimes gets changed/cleared depending on when the ‘child’ system data I send in via API is processed (Which is quite rightly done async!)

Can anyone shed some light if I have misconfigured something? It all makes my uploads through the API unreliable, so have to repeat the Output update of parent system regularly

The child links to the parent have definitely been removed, there does not appear to be any consumption recorded on the parent 84236 since the 13th Dec.

Thanks for confirming that. It’ll help understand what I see. I may get back with further questions.

Consumption is uploaded by the same script uploading the ‘child’ data so it is lagging behind :wink:

@bankstownbloke Apologies in advance for bothering you again.

Yesterday I ran my script to upload the data I pull from SolarEdge to upload 27-2 - 30-4 into the 3 child systems, but this time without the updates I had been doing to the parent.

This has been successful (until I ran out of API calls from 1-5 - as expected) and all these look good.

Unfortunately now the parent system sid=84236 seems to have Generation data closely matching the ‘Oost’ child, sid=86745 - The last of the 3 children I upload, and consumption data I had manually entered got lost.

I won’t need any help correcting anything…I can correct all through API, I have all the data…
But it would be nice if in the future all these systems will be fully independent. (The child system data is SolarEdge ‘string’ data, which seems to be before DC conversion losses, so slightly high - as such aggregation into the parent is not desirable)


Sorry, not sure what the problem is? The aggregation would overwrite any manual entries on the parent with data from the children.

Hi, thanks for your response.

But I have not configured them to, do not want nor expect the systems to aggregate.

So this behaviour is confusing me :wink: