Voltage measurement & reporting

Since 20.49.0 i see that the voltage data i am collecting shows periods at around 230/240V (grid voltage) and periods of around 425V.
Does anyone understand why this would be? Is this grid and battery voltages both being output as “voltage”? is there a way to separate the data into two fields if so?


Single phase only.

example of the data logged by PVOutput shown here

Goto the PW gateway address (https://192.168.x.x/api/meters/aggregates) to see what voltage is being reported.

Looking at the output you suggest, there are TWO instances of instant_average_voltage. One is inside the {} for site; one inside the {} for battery. PVOutput seems to be choosing randomly between them for what it returns - normally using battery and sometimes site.

Can you post an example here please.

here is a current example:

Yesterday morning i changed the instant_average_voltage to battery.instant_average_voltage. Since then it has stopped collecting any voltage readings and also any Power Used and the Energy used is zero.

e.g.: (screen shot uploaded)

I changed the line voltage=battery.instant_average_voltage back by dropping the battery prefix, and now I once again get mostly the line grid voltage with the occasional reading as above which is the site voltage.
Is there a bug in PVoutput where it incorrectly parses the JSON sometimes and can’t extract the battery.instant_average_voltage field? forgive my asking but it’s hard for me to see any other explanation.

The voltage setting doesn’t support prefixes, it either uses the voltage from load or solar.

If you have two integration services running then disable the voltage setting from the service uploading consumption as this would read the load voltage and possibly overwrite voltage from the solar from the other service.

To make sure that I am clear, I run 2 services. One direction = IN and one OUT. So disable it on the OUT service?

i want to show the Grid line voltage rather than the Solar voltage. That I assume is the LOAD voltage?

Thank you for being so responsive. I had thought that all parameters could read from the PW data and needed prefixes to get the right element.

From the sample above -

  • load voltage = 411V - uploaded by In direction Integration Service
  • solar voltage = 238V - uploaded by Out direction Integration Service

Comment out the one you don’t want, there should only be 1 service uploading voltages.

I have now removed the voltage= line from the IN service and left this in the OUT service, restarting both:
Since doing that, no voltage data is being shown or recorded even though I can see it in the JSON from the Powerwall when i look at that direct.

Looks like an issue with voltages on solar being a whole number, when the service is expecting a decimal number.

Thanks for the feedback, this has been fixed in the patch below -

Instructions on installing the patch -

update done and services restarted. Still not getting any readings. The voltages on solar are a decimal eg
“solar”:{“last_communication_time”:“2021-03-09T22:21:15.489108964Z”,“instant_power”:16.763381958007812,“instant_reactive_power”:187.43746948242188,“instant_apparent_power”:188.18558908865444,“frequency”:50.049781799316406,“energy_exported”:35728840.76583491,“energy_imported”:41947.86055713978,“instant_average_voltage”:245.7810821533203, …

I tried with with:

and separately with:

neither shows a voltage in the table or on the graph.

Strange, the data sample works fine here.

Look at the PW0-2021-03-10.log file in the log folder and check if it has voltage data on the 4th column.

This is the data that is saved prior to uploading.


This should be the working config.

Running with that configuration, here is the log file:
Voltage appears to be -1.0 which looks like some error flag?

OK - NOW WORKING THANK YOU with the revised .jar file.

I installed all the latest MS patches, restarted everything, and finally I now have 24 hours with correct voltage readings. thank you for fixing the bug! I may be a rare user who tracks the voltages; we are near the end of the run from the local power transformer so the resistance in the line is higher than for some. I have the power limit for import set on the PW gateway or I cause the line voltage to fall below regulation spec. I still like to track the variation.

Great, thanks for the feedback.

You might also be interested in the proposed voltage alerting feature below -