Tesla Powerwall2 data to PVoutput?


#123

This has been fixed, extended data will now show when not logged in.

For other issues, please raise separate topics as they are unrelated to Telsa Powerwall uploads.


#124

let me know if you get net metering working… I love what you have done with all your graphs and prediction stuff - I have two PV’s at https://pvoutput.org/intraday.jsp?id=61344&sid=55208 both extended data with powerwall2.


#125

Hi,

I would appreciate some help with getting this set up as I have been going round in circles all night with the error below. I managed to get the Window installer setup and working fine for a little over a day and then decided I would follow the additional steps to get the solar generation showing on the default page, what a mistake that turned out to be!

As soon as I got the second (solar generation) service running the timings on the Standard View were one hour ahead of the actual time (the timings on the original / extended view were correct), this is despite the values in the PVOutput.log and Log file showing the correct time. Because of this the original service stopped working as it was recognising on the status check that there was already an entry at a later time than it was attempting to upload.

Steps I have taken so far:

  • Reinstalled second service & followed config steps again to make sure I hadn’t missed anything
  • Reinstalled original service
  • Uninstalled second service
  • Waited for the hour to go by such that the original service could attempt to upload results

I am now in a situation whereby I get the following repeating error on the the original service:

2018-09-30 02:03:05,502 INFO [Thread-1] (Controller.java:731) - Startup Complete: Waiting for data…
2018-09-30 02:03:05,502 INFO [Thread-1] (Controller.java:1806) - >>> 20180930,02:05,-1,-1,-1.0,-42,-1000.0,248.8,-100,-42.849,43.005,49.989,5.213
2018-09-30 02:03:05,502 INFO [Thread-1] (WebClient.java:133) - >>> http://pvoutput.org:80/service/r2/addbatchstatus.jsp?data=20180930,02:05,-1,-1,-1.0,-42,-1000.0,248.8,-100,-42.849,,43.005,49.989,5.213
2018-09-30 02:03:05,764 WARN [Thread-1] (Controller.java:1838) - <<< [400] Bad request 400: Missing energy and power values [20180930,02:05,-1,-1,-1.0,-42,-1000.0,248.8,-100,-42.849,43.005,49.989,5.213]
2018-09-30 02:03:05,764 INFO [Thread-1] (Controller.java:1960) - <<< [400] 20180930,02:05,-1,-1,0

I have uninstalled and reinstalled the original service, I have deleted all live outputs from my system, I have even created a new system and gone through the entire config again from step 1, but no matter what I now do I always get this same error.

Can anyone shed any light on where I am going wrong?

Thanks!


#126

The system has the Daylight Savings setting enabled and will adjust for DST when data is uploaded. This setting should only be enabled if the uploader does not support DST. PVOutput Integration Service supports DST so this setting should be disabled.

image

The 400 errors are due to trying to upload extended data without generation/consumption data.

  • The first service should be uploading consumption and extended data.
  • The second service should be uploading solar only with extended data disabled.

#127

Thank you for your reply - I have not yet installed the second service again but have changed the DST setting for when I do.

As for the original service I have had it working for approximately one hour before it started to throw the 400 error repeatedly, e.g. the uploads for 19:30 BST through to 20:20 BST worked fine but the upload for 20:25 and subsequent entries failed:

2018-09-30 20:24:04,865 INFO [Thread-1] (Controller.java:1806) - >>> 20180930,20:25,-1,-1,-1.0,-5,-1000.0,246.7,-10,-5.376,-13.42,63.773,4.126
2018-09-30 20:24:04,866 INFO [Thread-1] (WebClient.java:133) - >>> http://pvoutput.org:80/service/r2/addbatchstatus.jsp?data=20180930,20:25,-1,-1,-1.0,-5,-1000.0,246.7,-10,-5.376,,-13.42,63.773,4.126
2018-09-30 20:24:05,148 WARN [Thread-1] (Controller.java:1838) - <<< [400] Bad request 400: Missing energy and power values [20180930,20:25,-1,-1,-1.0,-5,-1000.0,246.7,-10,-5.376,-13.42,63.773,4.126]
2018-09-30 20:24:05,149 INFO [Thread-1] (Controller.java:1960) - <<< [400] 20180930,20:25,-1,-1,0

If I am reading the Output log file correctly field 5 is Power (varies) and 6 is energy (always -1.000), although the log entry above states it is for 20:25 BST it appears to be using the reading from 20:23 BST:

20180930;20:23:43;-1000.0;246.7;-5;-1.000;-1.000;-10.000;-5.376;NaN;-13.420;63.773;4.126

Am I right in thinking that it is complaining about the Power field showing a negative value (as if I were exporting to the grid)? It seems the Powerwall sensors are a little sensitive as there are a small number of occasions in the output log file when the power value goes negative. It probably doesn’t help that at times there is very little load from the house as I have noticed on the PW app that it sometimes just shows blank icons for House, Grid, Solar & PW as if it cannot read such low W load values.

Is there a way that I can prevent this from ‘crashing’ the upload? Something like the rule that you suggested a few months back for “nswfugitive” - e.g.

rule=if (power < 0 && out) power = 0;

Also, is there a way of editing the data it is attempting to upload so that I don’t lose this information or get gaps in the graphs?

Thanks


#128

Well in the time it took me to write that reply and attempt to figure out what was going on it has skipped past the 20:25 entry and begun uploading again - I assume it only holds the last 4 or so of read history from the PW while uploading?

I have also setup the second service, changed the direction to out on powerwall.ini and commented out the V7-V12 entries, the generation upload appears to be working albeit it is registering <5W generation despite it being pitch black outside - is that another rule entry in the powerwall.ini file?

rule=if (power < 20 && out) power = 0;


#129

Yes, the rule is placed in powerwall.ini