Powerwall not loading data


I’ve had PVOutput recording my SolarEdge data for a while. Just had a Powerwall 2 installed and trying to set up the new Gateway data output. Using Mikesgear tutorial, after a few glitches with Java etc, I’ve managed to get the start-service batch file to run and it’s definitely running continuously, but after 2 hours, no data appears in PVOutput. The only possible clue in the pvoutput.log file is the following repeating lines (plus serveral more lines that look OK):

2019-08-07 19:48:38,006 INFO [Thread-2] (WebClient.java:162) - >>>
2019-08-07 19:48:38,069 ERROR [Thread-2] (AHttpLogReader.java:462) - Http Error
javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated

Apart from that I can only think that I haven’t put in the correct stuff in Settings. After donating to get the extended setup I initially tried adding the extended settings to my original SolarEdge System settings, but that didn’t seem to work so I generated a new System with a new api code etc for the Powerwall Gateway output.

Any clues? Any advice much appreciated.


I’ve partly solved the problem. Should have used https (as shown in my browser!) instead of http. However that didn’t get the battery state of charge to display, although the log indicates that it’s being read without error now. Work in progress!


I’ve got it working - and yes, it now needs to be https for both. For State Of Energy It may not be a problem with the upload, it might also be an issue with the graphing settings for that extended variable. https://pvoutput.org/intraday.jsp?id=64310&sid=57175 shows SOE working!


Seems none of the extended parameters which include soe is being recorded, check that the data is being sent in the pvoutput.log file, look for addbatchstatus.jsp with the soe data on the same line.

If not try restarting the service.


Hi Bankstownbloke

It looks like your suggestion is on the right track. my addbatchstatus.jsp line has all the api/meters/aggregates variables, but the v11 data from api/system_status/soe is missing. two comma’s with nothing between them. The v9 temperature parameter is missing too. My PVO log file also has NaN in those two positions, which, I understand, means Not-A-Number, but I assume that’s because it’s trying to calculate something using the missing variable.

I followed the MIkesgear instructions re. entering https://x.x.x.x/api/system_status/soe in a browser and that produces the percent charge figure correctly, but it’s not being read by the batch file for some reason.

I just found the Energy Monitors>Powerall threads and the Extended Parameters thread, where maybe I should have posted this, but the info there doesn’t seem to help. I’m running the Integration Service v1.5.2 which I assume is the most up to date.


Thanks Willisave. https solves the basic problem. Still not loading SOE though. I don’t think it’s the graph setup. The PVOutput log file indicates that it’s not reading that part of the data, as noted in my reply to bankstownbloke. Here’s the output I’m getting at the moment: > https://pvoutput.org/intraday.jsp?id=74321&sid=69241


Seems to be working now -


Yes, but no battery state. The data column is empty. Seems to be due to not reading the soe output. As I said, the batch file indicates null in that position. Rather puzzling - to me as a non-programmer anyway. Temperature is missing as well, but I may not have configured the temp output properly. Not bothered about that at the moment.


PS - here’s a section of the pvoutput.log file.


Your integration software may be out-of-date - you mention above you are running version 1.5.2.

Try downloading the latest version, with the patch for the SOE that was added in (see Powerwall - Extended Parameters and Tesla Powerwall2 data to PVoutput?)??

Here’s the same section from mine yesterday…

2019-08-13 16:39:02,057 INFO [Thread-2] (WebClient.java:243) - >>> https://powerwall:443/api/meters/aggregates
2019-08-13 16:39:02,104 INFO [Thread-2] (WebClient.java:155) - >>> https://powerwall/api/system_status/soe
2019-08-13 16:40:02,229 INFO [Thread-2] (WebClient.java:243) - >>> https://powerwall:443/api/meters/aggregates
2019-08-13 16:40:02,307 INFO [Thread-2] (WebClient.java:155) - >>> https://powerwall/api/system_status/soe
2019-08-13 16:41:02,432 INFO [Thread-2] (WebClient.java:243) - >>> https://powerwall:443/api/meters/aggregates
2019-08-13 16:41:02,526 INFO [Thread-2] (WebClient.java:155) - >>> https://powerwall/api/system_status/soe
2019-08-13 16:42:02,651 INFO [Thread-2] (WebClient.java:243) - >>> https://powerwall:443/api/meters/aggregates
2019-08-13 16:42:02,792 INFO [Thread-2] (WebClient.java:155) - >>> https://powerwall/api/system_status/soe
2019-08-13 16:43:02,979 INFO [Thread-2] (WebClient.java:243) - >>> https://powerwall:443/api/meters/aggregates
2019-08-13 16:43:03,011 INFO [Thread-2] (WebClient.java:155) - >>> https://powerwall/api/system_status/soe
2019-08-13 16:43:35,276 INFO [Thread-1] (Controller.java:1806) - >>> 20190813,16:45,-1,-1,-1.0,721,-1000.0,238.7,340,721.698,177.3,100,156.49
2019-08-13 16:43:35,276 INFO [Thread-1] (WebClient.java:133) - >>> http://pvoutput.org:80/service/r2/addbatchstatus.jsp?data=20190813,16:45,-1,-1,-1.0,721,-1000.0,238.7,340,721.698,,177.3,100,156.49
2019-08-13 16:43:35,682 INFO [Thread-1] (Controller.java:1834) - <<< 20190813,16:45,1

My SOE was 100%, giving the ‘100’ in the second-last field where yours is missing a value.

Interesting that your log has the SOE being read in ‘PowerwallLogReader.java’ different from the ‘Webclient.java’ that is reading the main variables - whereas mine is being read in ‘WebClient.java’ for both, due to having the SOE patch fixed (which fix was to funnel the SOE read through Webclient.java, which does all the SSL magic for HTTPS to work)


Also…to save some chasing…

Tesla PW2’s don’t record/report temperature in this API, only voltage. Its normal that the v9 is empty here.


That did the trick! Many thanks for your help, willisave and BB. I’ve upgraded to V5.4.1 and now have Battery State. Thanks also for the advice on temperature. I need to consider an alternative source.