Fronius inverter power monitor for iOS / iPhone / iPad

This post was flagged by the community and is temporarily hidden.

1 Like

nice

I use http://fronius-powermon.duckdns.org/
but it requires a corsproxy to get it to run.
how did you get around that? and do you have an android app or is it IOS only?

This post was flagged by the community and is temporarily hidden.

1 Like

Hi @B-Man . I have a very early draft app for Android, if you’d be interested to test it. I’ve been running it on my Android TV no problems. It is a replica of the same charts I have for iOS. You can input the IP address for your inverter in the Configuration page and it should work from there.

I haven’t released this Android app to the Google Play Store yet because its far too early. So I have the app as an APK file. If you have experience in side-loading Android apps you’ll know what to do. Otherwise I can explain how if you are interested.

If you visit the following page:

The APK file is named Fronius3_1.apk. Just download on your Android device and install (ie. side load) and should be good.

Doesn’t seem to work says it can’t find inverter but it’s definately the correct ip address.

Formatting doesn’t suit either

Thank you B-Man. I’m disappointed the charts aren’t scaling to fit within your portrait orientation. Its the same script I run in my iPhone and it scales.
Looks like I’ll need a test for portrait mode. My only physical android device is an Android TV that always runs landscape and the app is fine. Thank you I’ll investigate under portrait.
Sad the ip address doesn’t seem to work. Just a FYI the app just hits your inverters solar web API directly through the ip address. If you can test this url, replacing “your IP address” with your ip address, in your device’s browser to confirm it’s working…
http://your IP address/solar_api/v1/GetPowerFlowRealtimeData.fcgi
To ensure there’s no odd error. You should get a clean response of (JSON) data like…
{
“Body” : {
“Data” : {
“Inverters” : {
“1” : {
“DT” : 1,
“E_Day” : null,
“E_Total” : etc…

   "Body" : {
      "Data" : {
         "Inverters" : {
            "1" : {
               "DT" : 232,
               "E_Day" : 21150,
               "E_Total" : 85693104,
               "E_Year" : 6779009.5,
               "P" : 0
            }
         },
         "Site" : {
            "E_Day" : 21150,
            "E_Total" : 85693104,
            "E_Year" : 6779009.5,
            "Meter_Location" : "load",
            "Mode" : "vague-meter",
            "P_Akku" : null,
            "P_Grid" : 391.01214000632569,
            "P_Load" : -391.01214000632569,
            "P_PV" : null,
            "rel_Autonomy" : 0,
            "rel_SelfConsumption" : null
         },
         "Version" : "12"
      }
   },
   "Head" : {
      "RequestArguments" : {},
      "Status" : {
         "Code" : 0,
         "Reason" : "",
         "UserMessage" : ""
      },
      "Timestamp" : "2024-06-05T21:26:05+09:30"
   }

Well thats good news. I’d say its the poor UI layout then in portrait mode blocking the entry of the ip address. I’ve done a lot of testing of valid and invalid ip addresses and had no problems. The app is attempting to query that url with the ip address you enter every second so you should be getting a realtime response on any change you make in that. I’ll get that portrait orientation working

This post was flagged as spam … somehow

Ok I’ve replicated your screen size on my end and I suspect its 540 x 960 pixels. Its the lowest resolution I can set in my emulator. My guess is this is a small mobile phone? I have the app defaulting to the opposite screen size of a big screen TV.
I’ve managed to configure most of it down to your size. This is how it’s looking now for your screen size …


To achieve this you need to go to Configuration and set the “Gauges Width” to “100”, the “Gauges Height” to “60” and “Font Size” to “10”.
Some of these changes need the app to stop and start again (I’ll fix this soon). So stop the app after making this update and start again.
I did notice in the emulator that changing my IP address to a wrong address, and then changing it back to the correct address, fails to continue monitoring, but restarting the app works. So for now after updating the Configuration best to stop (force stop) the app and start again. I’ll try and add a button to the app to have it restart if possible.
Because I’m new to these forums I can only add one screenshot per post :wink:

Perhaps this was the spam, so I have removed it

Actually I worked out how to add a “Stop App” button to the Configuration. So after setting your config (IP Address etc) click “Stop App”, the app will force stop, then open the app again and hopefully its working.
This is v0.3 of the app available at the same link as before.

several of my posts are flagged as spam for some reason and are hidden

I redownloaded it but there’s no stop app. or font size
and after applying the graph changes and going back to main it doesn’t refresh.
it appears as you have probably worked out that its not applying the changes via the menu.

it looks like if I close the app and reopen it the changes have been applied and its showing but the graph still isn’t suited to the phone.
its a Samsung S21.

v0.3 definitely has the font size config. I must be careful the words I post here, anything I say can be taken as spam. Can’t send you the link but I’ll post screenshots

image

I got this one and installed it to my emulator and it has the font size config…

I change gauges width to 100, gauges height to 60 and font size to 10 and click stop app and open the app again and looks like this…

I’m open to suggestions on how to better format the charts at this resolution.

Maybethe file isn’t updated on git hub?

I don’t get stop app or font…

I downloaded it from the same screenshot as above. Where it says v0.3. I uninstalled the app from my android device (emulator) and confirmed the app icon was removed from the screen. Then imported and installed this downloaded v0.3 apk ensuring it is the one I just downloaded. Then opened the app and font size is there. I took that extra precaution of uninstalling the one I had before installing v0.3 just to be absolutely sure it updated. Perhaps trying uninstalling the existing one first. Shouldn’t need to but just in case.

I’m actually performing the same steps as you are in my testing. I develop the app on one device, post it to github, and pull it from GitHub just like you on the test device. My test device only receives releases.

My bad. The link points to v0.1

All seems to show ok.

Looks a bit crammed on the phone.
Would be good on the TV like you say.

Event log button doesn’t show anything

Its less crammed if you rotate your phone sideways to landscape. Here is my emulation of your phone in portrait …